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MPLAB IDE v8.10 rövid bemutatása

I. számú melléklet

MPLAB IDE v8.10 rövid bemutatása

A  mikrovezérlőre  történő  fejlesztés  nehéz  és  bonyolult  feladat  – amennyiben  nem  áll 
rendelkezésünkre egy könnyen kezelhető, és teljes körű szoftverállomány egyenesen kilátástalannak 
tűnik. A Microchip cég – fő terméke , a PIC mikrovezérlők terjedésének felgyorsítása érdekében – a 
microcontroller  fejlesztéshez szükséges  szoftverállományt  egy integrált  fejlesztőkörnyezet  (IDE-
Integrated Development Environment) formájában ingyen biztosítja a felhasználók részére. Az IDE 
rendszerek leveszik a  fejlesztő  válláról  az  egyes  programok,  ill.  a  különböző fejlesztőeszközök 
kompatibilitásának problémáját. Egy mikroprocesszoros rendszer felprogramozásához a következő 
szoftverekre van szükségünk:

• Editor: melyben a program forráskódját meg tudjuk írni. Az editornak alkalmazkodnia 
kell a programozó speciális igényeihez (keresés, csere, ugrás sorra, szintaktikai jelzések, 
stb.)  és  meg  kell  kímélni  őt  a  munkája  során  felesleges  funkcióktól  (helyesírás 
ellenőrzés, betűtípus, formázás, stb.).

• Fordítóprogram1:  melynek  segítségével  a  forráskódból  a  mikroprocesszor  számára 
feldolgozható gépi kódot tudunk készíteni.

• Programozó  szoftver:  mely  –  a  szükséges  hardverelem(ek)  segítségével  –  el  tudja 
végezni a mikroprocesszoros rendszer konfigurálását a fordító által generált programozó 
fájl alapján.

A fent  felsorolt  szoftverek  elengedhetetlenek  a  mikrovezérlő  fejlesztéshez  is.  Ezeken  felül  az 
MPLAB IDE biztosít számunkra még egy egyszerű szimulátor programot  – valamint a magasabb 
számú verziói a Microchip által gyártott hardverelemeket (ICD, ICD2, ICE) is támogatja.

A következőkben betekintést nyújtunk az MPLAB kezelésébe, fontosabb funkcióiba.

1 PIC mikrovezérlők fejlesztése során kereszt-fordítót (cross assembler) használunk – a mikrovezérlőt működtető 
programot egy másik mikroszámítógépen (általában PC-n) generáljuk.
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A menürendszer felépítése

Az  MPLAB  IDE  a  Windows-os2 programoknál  már  megszokott  legördülő  menürendszert 
alkalmazza, kiegészítve a használatát megkönnyítő ikonokkal, és gyorsbillentyű kombinációkkal.

File:

• New: Új fájl létrehozása.
• Add  New  File  to  Project...: Új  file  hozzáadása  a 

projekthez.
• Open...: Létező fájl megnyitása.
• Close: Aktív megnyitott fájl bezárása.

• Save: Fájl mentése.
• Save As...: Fájl mentése más néven.
• Save All: Minden megnyitott fájl mentése.

• Open Workspace...: Munkaasztal megnyitása.
• Save Workspace: Munkaasztal mentése.
• Save  Workspace  As...: Munkaasztal  mentése  más 

néven.
• Close  Workspace: Aktív  megnyitott  munkaasztal 

bezárása.

• Import...: Debug  fájl,  vagy  futtatható  hex  fájl 
importálása.

• Export...: Hex fájlba történő exportálás.

• Print...: Nyomtatás.

• Recent Files: Legutóbbi fájlok megnyitása.
• Recent  Workspaces: Legutóbbi  munkaasztalok 

megnyitása.
 

• Exit: Kilépés az MPLAB-ból.

2 Linux operációs rendszert használók futtathatják WINE alól – vagy használhatják a PIKDEV IDE rendszert 
mikrovezérlők fejlesztésére.
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Edit:
• Undo: Visszavonás.
• Redo: Ismétlés.

• Cut: Kijelölt szöveg másolása a vágólapra és eredeti 
helyéről való törlése (kivágás).

• Copy: Kijelölt szöveg másolása a vágólapra.
• Paste: Vágólapon lévő szöveg beillesztése.
• Delete: Kijelölt szöveg törlése.

• Select All: Aktív fájlban minden szöveg kijelölése.

• Find...: Kulcsszó keresése szövegben.
• Find Next: Következő keresése.
• Find in Files...: Fájlban történő keresés.
• Replace...: Sztring cserélése szövegben.
• Go To...: Ugrás a szövegben címkére, vagy sorra.

• Properties...: Tulajdonságok (Az editor beállításai).

• Uppercase: A  kijelölt  szövegben  legyen  minden 
nagybetű.

• Lowercase: A  kijelölt  szövegben  legyen  minden 
kisbetű.

• Comment Block: A kijelölt szöveg legyen megjegyzés.
• Uncomment Block: A kijelölt szöveg lefordítandó kód 

legyen.
• Indent  Block: Kijelölt  szöveget  egy  tabulátorral 

beljebb.
• Outdent  Block: Kijelölt  szöveget  egy  tabulátorral 

kijjebb.
• Match: Keresd meg a kurzornál lévő kapcsos zárójel 

párját.

• Toggle Bookmark: Kijelölt sor ellátása könyvjelzővel.
• Next Bookmark: Ugrás a következő könyvjelzőre.
• Previous Bookmark: Ugrás az előző könyvjelzőre.
• Clear  All  Bookmarks: Minden könyvjelző  törlése  az 

aktuális fájlban.
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View:
• Project: Projekt ablak mutatása.
• Output: Kimeneti fájl mutatása.

• CPU  Registers: A  mikroprocesszor  regisztereinek 
megjelenítése (csak PIC32MX-nél).

• Call Stack: dsPic esetén ebben az ablakban férhetünk 
hozzá a futtatható kódban szereplő  meghívásokhoz és 
ugrásokhoz.

• Disassembly  Listing: Forráskód  visszafejtése 
assemblyre, és gépi kódra.

• EEPROM: Belső  EEPROM  tartalmának 
megjelenítése.

• File Registers: Az összes fájlregiszter mutatása.
• Flash  Data: A/D  átalakítóhoz  vagy  komparátorhoz 

tartozó  flash  adatmemória  elérése  (PIC12F519; 
PIC16F526).

• Hardware Stack: A verem tartalma és a veremmutató 
helyzete.

• LCD  Pixel: Megjeleníti  az  LCD  kimenetre  írt 
pixeleket.

• Locals: Magas  szintű  nyelven  írt  forráskódban 
tudhatunk meg a változókról információt.

• Memory: A  mikroprocesszor  program  és/vagy 
adatmemóriájának megtekintése (csak PIC32MX-nél).

• Program  Memory: Program  memória  tartalma 
hexában, és ASCII-ban.

• Special  Function  Registers: Speciális  funkciójú 
regiszterek megjelenítése.

• Watch: Watch (figyelő) ablak megnyitása.

• Memory  Usage  Gauge: Memória  kihasználtság 
mutatása.

• Simulator Trace: A processzor műveleteinek nyomon 
követése.

• Simulator  Logic  Analyzer:  Egy  logiakai  analizátort 
tudunk  elindítani  (természetesen  csak  szimulációs 
környezet).

• Standard: Szokásos eszköztár.
• Project Manager: Projekthez tartozó eszköztár.
• Checksum: Ellenőrző összeg megjelenítése.
• Debug: Hibakereső eszköztár (csak ha ki van választva 

hibakereső eszköz).
• MPLAB ICD 2 DebugToolbar: MPLAB ICD 2 

hibakereső eszköztár (csak ha ICD2 van debug 
eszközként ki választva).

• Resources: Hibakeresőhöz tartozó töréspontok.
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Project:

• Project Wizard: Projekt varázsló.

• New...: Új projekt létrehozása.
• Open...: Projekt megnyitása.
• Close: Projekt bezárása.
• Set Active Projekt: Aktív projekt kiválasztása.

• Quickbuild  (*.asm  file): Aktív  asm  forráskód 
gyorsfordítása (projekt nélküli munkát tesz lehetővé).

• Clean: Törli  az  aktív  projekt  közbenső  fájlait  (hex-; 
object-; debug fájl).

• Export Makefile: 
• Build All: A projekt összes fájljának fordítása.
• Make: Azon fájlok fordítása,  melyek megváltoztak a 

legutóbbi fordítás óta.
• Build Configuration: Fordítás konfigurálása (Release: 

„éles működésre”; Debug: Hibakeresésre (csak ICD2, 
vagy REAL ICE)).

• Build  Options: Fordítás  tulajdonságainak  beállítása 
(forráskódé; projekté).

• Save Project: Projekt mentése.
• Save Project As...: Projekt mentése más néven.
• Add Files to Project: Fájl hozzáadása a projekthez.
• Add  New  File  to  Project...: Új  fájl  létrehozása  a 

projekten belül.
• Remove  File  From  Project: Fájl  eltávolítása  a 

projektből.

• Select  Language  Toolsuite...: Fordítóeszközök 
(programok) kiválasztása.

• Set  Language  Tool  Locations...: Fordítóeszközök 
helyének kijelölése (elérési út).

• Version Control...: Megnyitja a verzió kezelő rendszert 
–  mellyel  régebbi  fejlesztőkörnyezettel  elkészített 
projektet/fájlt tudunk naprakésszé tenni.
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Debugger:

• Select Tool: Debugger eszköz kiválasztása.
• Clear Memory: Memória törlése.
• Run: Futtatás.
• Animate:  Lassú  (default:  1  utasítás  =  300msec) 

futtatás.
• Halt: Megállítás.
• Step Into: Lépésenkénti futtatás.
• Step Over: Lépésenkénti futtatás – szubrutin átugrása.
• Step Out: Szubrutinból való kilépés.
• Reset: Reszet.
• Breakpoints...: Töréspontok.
• StopWatch: Időmérő eszköz.
• Complex Breakpoints: Összetett töréspontok.
• Stimulus: I/O  lábakra  adhatunk  gerjesztést, 

regisztereknek adhatunk kezdőértéket.
• Profile: Statisztikai  információt  szolgáltat  a 

hibakeresés  során  addig  végrehajtott  programrészről 
(utasítások száma, típusa, végrehajtási idő).

• Clear  Code  Coverage: Amennyiben  a  hibakereső 
beállításaiban  engedélyezve  van,  törölhetjük  a 
végrehajtandó  kód  kijelölését  (végrehajtás-
analizátorhoz  hasonló  funkciót  valósíthatunk  meg  a 
kódlefedés  vizsgálatának  segítségével  szimulációs 
környezetben).

• Refresh  PM: Programmemória  frissítése  a  program 
újraindításakor.

• Settings...: A hibakereső beállításai.

A hibakereső  működtetéséhez  tartozó  menüpontok  csak  eszköz  kiválasztásakor  jelennek 
meg  –  és  függenek  az  adott  eszköztől.  Itt  az  MPSIM debuggerhez  tartozó  menüpontokat 
ismertettük.

• None: Nincs eszköz kiválasztva.
• MPLAB ICD 2: Microchip ICD2 In-Circuit Debugger.
• MPLAB ICE 4000: Emulátor (teljes sebességet tudja).
• MPLAB SIM: Szimulációs környezet.
• MPLAB  ICE  2000: „teljes-értékű”  emulátor  (kis 

megkötés: max. 25 MHz).
• REAL ICE: Valós  idejű  emulátor,  használható  az  új 

nagy sebességű mikrovezérlőkhöz; dsPIC-hez is.
• PICkit 2: Lebutított ICD2 (kevés típust ismer).
• PIC32MX Starter Kit: 32 bites mikrovezérlő debugger.
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• All Memory: Minden memória törlése.

• Program Memory: Programmemória törlése.
• GPRs: Általános célú regiszterek törlése.
• EEPROM: EEPROM törlése.
• Configuration Bits: Konfigurációs bitek törlése.

Programmer:

• Select Programmer: Programozó hardver kiválasztása.

A  Programozó  menüpontok  –  a  hibakeresőhöz  hasonlóan  –  a  kiválasztott  eszköztől 
függenek. Jelen esetben nincs kiválasztva eszköz.

• None: Nincs kiválasztva programozó.
• PICSTART  Plus: Elavult  soros  programozó  eszköz 

(max.  40  lábú  DIP tokos  verziókhoz;  ma  már  nem 
használják).

• MPLAB  ICD  2: USB-s  Debugger,  melyet 
programozásra is használhatunk (ICSP funkció van).

• AN851  Quick  programmer  Beta: A  megfelelő 
bootloader program segítségével a PC soros portján is 
felprogramozhatjuk a PIC-et (PIC16F87XA;PIC18F). 
A  bootloader  program  azonban  elvesz  a  program 
memóriából!

• PICkit  2: ICD2  olcsóbb  kivitelben,  programozásnál 
ugyanúgy működik.

• MPLAB PM 3: Univerzális – igen drága – programozó 
(az adatot tudja SD/MMC kártyákra/ról is tölteni).

• REAL ICE: A valós  idejű emulátort  is  használhatjuk 
programozásra.

• PRO MATE II: Soros programozó, mellyel microchip 
memóriákat is lehet égetni.

• PICkit1: Csak 8-bites kontrollerekhez jó (ma már nem 
használják).
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Tools:
• Matlab/Simulink: Szabályozástechnikai  hatásláncok 

szimulálására kifejlesztett keretprogram.
• Gimpel  PC-Lint/MISRA:  C  programnyelvhez 

illeszkedő  nyelvi  ellenőrző  és  hibakereső  beépülő 
modul.

• Data  Monitor  And  Control  Interface: Programfutás 
közben előre rögzített vezérlőjeleket biztosíthatunk és 
megvizsgálhatjuk ezeknek hatásait akár grafikusan is.

• MPLAB  Macros: Microsoft  makrók  használatának 
engedélyezése az MPLAB IDE fejlesztőrendszerben.

• RTOS  Viewer: Megjeleníti  a  valós  idejű  operációs 
rendszer  ablakát,  ha  telepítve  van,  és  az  aktív 
projektünkhöz includoltuk.

• Keeloq Plugin: Keeloq ugrókódos titkosításhoz tartozó 
kiegészítő.

• AN908  ACIM Tuning  Interface: AC motor  hangolás 
dsPIC esetén.

• AN901 BLCD Tuning Interface: Érzékelő és szénkefe 
nélküli DC motorok hangolása szintén dsPIC-hez.

• Visual  Initalizer: Egy  vizuális  programnyelv 
segítségével  állíthatjuk  be  a  perifériák  és  a   PIC 
tulajdonságait.

Configure:
• Select Device: Eszköz kiválasztása (PIC; Keeloq IC; 

Microchip EEPROM).
• Configurations Bits...: Konfigurációs bitek beállítása.
• External  Memory...: Külső  memória  illesztése  (csak 

arra alkalmas eszköznél és konfigurálásnál).
• ID Memory...:  Felhasználói azonosítót rendelhetünk a 

programhoz.

• Settings...: Az MPLAB beállításai.
Window:

• Close All: Minden ablak bezárása.

• Cascade: Ablakok egymáson történő elhelyezése.
• Tile Horizontally: Vízszintes elrendezés.
• Tile Vertically: Függőleges elrendezés.
• Arrange Icons: Ikonok rendezése.

• Window  Sets: Behívhatunk  egy  elmentett 
ablakelrendezést.

• Create  Window  Set...: Elmenthetjük  az  aktuális 
ablakelrendezést.

• Destroy  Window  Set...: Törölhetünk  elmentett 
ablakelrendezést.
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Help:
• Topics...: Tartalom.
• Release Notes: Kiadási jegyzék (napló).
• Driver Installation: Driverek telepítése a jegyzékből.
• Check  for  Updates...:  Újabb programverzió  keresése 

az interneten.
• Web Links: Mircochipes internetcímek jegyzéke.

• About MPLAB IDE...: Az MPLAB részletes névjegye.
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Eszköztárak

Standard (Szokásos) eszköztár:

Project (Projekt) eszköztár:

Debugger (Hibakereső) eszköztár:

Programmer (Programozó) eszköztár:

Checksum (Ellenőrző összeg, itt read-only):

A checksum nem sorolható be az eszköztárak közé – külön egységet alkot. A debugger és a 
programmer eszköztárban szereplő ikonok függenek a kiválasztott eszköztől (a jegyzetben 
az  MPSIM-hez  (hibakereső)  és  az  ICD2-höz  (programozó)  tartozó  eszköztárat  vettük 
alapul).

A standard eszköztár ikonjainak funkciója:

New File (Új fájl)

Open File (Fájl megnyitása)

Save File (Fájl mentése)

Cut (Kivágás)

Copy (Másolás)

Paste (Beillesztés)

Print File (Fájl nyomtatása)

Find (Keresés)

Find in File (Keresés fájlban)

Help (Segítség)
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Projekt eszköztár ikonjainak funkciója:

Build Configuration (Fordítási konfiguráció)

New project (Új projekt)

Open project (Projekt megnyitása)

Save Workspace (Munkaasztal mentése)

Build Options (Fordítási beállítások)

Toolsite Info
(Információ a kiválasztott
fordítóeszközről, pl. MPASM)

Make
(Az utolsó fordítás óta
megváltozott fájlok fordítása)

Build All (Mindent fordít)

Export Makefile

Programmer eszköztár ikonjainak funkciója:

Program target device 
(Írás a fejlesztett eszközbe)

Read target device 
(Olvasás a fejlesztett eszközből)

Reads device EEPROM 
(EEPROM memória olvasása az eszközből)

Verify target device memory
(Az eszköz memóriájának ellenőrzése)

Erase target device
(Az eszköz memóriájának törlése)

Verify target device is erased
(Ellenőrzés, hogy az eszköz ürese-e)

Release from Reset
(Kilépés a reszet feltételből (L → H))
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Hild in Reset
(Belépés a reszetfeltételbe (H → L))

Reset and Connect to ICD
(Reszet és ICD csatlakoztatás)

Debugger eszköztár ikonjainak funkciója:

Run (Futtatás)

Halt (Megállítás)

Animate (Lassú futtatás)

Step Into (Léptetés)

Step Over (Léptetés, ciklus kihagyása)

Step Out (Kilépés a ciklusból)

Reset (Reszet)

Breakpoint (Töréspont)
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Status Bar (Állapot sor):

Számozás Megnevezés Példa Megjegyzés

1 Aktuális hibakereső 
eszköz MPLAB SIM

Láthatjuk az aktuális programozó 
eszközt (A Debugger menüben 

tudunk változtatni)

2 Aktuális programozó 
eszköz MPLAB ICD 2

Láthatjuk az aktuális programozó 
eszközt (A Programmer menüben 

tudunk változtatni)

3 Aktuális processzor PIC18F452
Az aktuális processzort mutatja (A 

Configure → Select Device menüben 
tudunk változtatni)

4 A programszámláló 
aktuális értéke pc:0

Kijelzi a programszámláló aktuális 
értékét – dupla kattintással új értéket 

tudunk megadni.

5 A munkaregiszter 
aktuális értéke W:0 Kijelzi a W regiszter értékét.

6 Státusz bitek n ov z dc c Ami nagybetűvel van írva az 1-ben, 
ami kisbetűvel, az 0-ban áll.

7 Töréspontok 
engedélyezése Bk On Amennyiben nincs kiválasztva, akkor 

nem engedélyezi a töréspontokat.

8 A processzor frekvenciája 20 MHz Az aktuális processzor 
frekvenciájának jelzése

9 Bankinformáció bank0 Mutatja az aktuális bankot

10* Sor- és oszlopszám az 
aktuális ablakban Ln 1, Col 1 Kijelzi az aktuális sor- (Ln) és oszlop 

(Col) számot a fájlban 

11* Beillesztés INS

Jelzi, hogy a billentyűzeten be van-e 
kapcsolva az insert (beillesztés) 

funkció. (INS → be van kapcsolva 
OVR → nincs bekapcsolva).

12* Írható, vagy csak 
olvasható WR

Amennyiben szerkeszthető a fájl, 
akkor WR jelzést látunk, ha csak 

olvasható, akkor RO-t

*: Csak akkor aktívak, ha a szövegszerkesztő ablakban vagyunk.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Programfejlesztés az MPLAB fejlesztőkörnyezetben

Az MPLAB IDE ún. projekt-workspace rendszerben dolgozik.

Projekt: Ebben  az  entitásban  tároljuk  a  fejlesztéshez  szükséges  fájlokat  –  forrásfájl  (*.c; 
*.asm;  stb.),  header  fájlok (*.inc;  *.h),  átmeneti  fájlok (object;  linker;  error fájl), 
futtatható állomány (*.hex).  A projektrendszer lehetővé teszi,  hogy a fejlesztéshez 
szükséges minden fájlt egy egységként kezeljük.

Workspace: A fejlesztendő eszközről (típus; fordító; debugger; programozó; stb.) és az MPLAB 
beállításairól  (ikonrendezés;  eszköztárak;  ablakok  elrendezése;  megnyitott  fájlok, 
projektek; stb.) hordoz információt.

Fejlesztés lépései az MPLAB-ban:

• Projekt létrehozása és beállítása

• Workspace beállítása

• Forrásfájl(ok) létrehozása, elkészítése, módosítása

• Header fájlok létrehozása, elkészítése, módosítása

• A források átolvasása, elemzése, ellenőrzése (előzetes szintaktikai és logikai analízis)

• Fordítás (szintaktikai ellenőrzés)

• Hibakeresés (Szimulátor; Debugger; Emulátor; Éles teszt)

• Projekt és workspace elmentése
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Az MPLAB-ban történő munkavégzés előtt állítsuk be a fejlesztőrendszer tulajdonságait!

Kattintsunk a Configure → Settings... menüpontra!

A felbukkanó ablakban a munkaasztalra (Workspace), a hibakeresőre (Debugger), a program 
letöltésre  (Program Loading),  a  gyorsbillentyűkre  (Hot  Keys),  a  projektre  (Projects),  és  egyéb 
beállításokra vonatkozó opciókat találunk.

Workspace-re vonatkozó beállítások:

Automatically save workspace upon closing: Munkaasztal  automatikus  mentése  az 
MPLAB  bezárásakor  (igen,  nem, 
rákérdez).

Reload last workspace at startup: A  legutóbbi  munkaasztal  betöltése  az 
MPLAB indításakor.

Recent fájl list contains: „Legutóbbi  fájlok”  maximális  száma 
(File → Recent Files).

Recent workspace contains: „Legutóbbi  munkaasztalok”  maximális 
száma (File → Recent Workspace).

Always show full path in recent file
and workspace lists: A  legutóbbi  fájlok  és  munkaasztalok 

teljes elérési útjának mutatása.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Debugger-re vonatkozó beállítások:

Automatically save files before running: Fájlok  automatikus  mentése  futtatás 
előtt.

Remove breakpoints upon importing a file: Fájlimportáláskor a töréspontok törlése.

Reset device to the beginning of main function: Az eszköz reszetelése a main függvény 
(C nyelv) előtt.

Stepping Behavior (Léptetési módok):
Track debugger location in the source code: A  hibakereső  helyzetének  nyomon 

követése  a  forráskódban  (Trace  ablak 
megnyitása).

Browse for source if file is not found: Amennyiben  nem  található  a  forrás, 
akkor tallózás lehetőségének felajánlása.

Show disassembly if source is unavailable: Disassembler  ablak  megnyitása,  ha  a 
forrás nem elérhető.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Program Loading beállítások:

Clear memory before building a project: Memória törlése a projekt fordítása előtt.

Clear memory after successfully
building a project: Memória  törlése  a  projekt  sikeres 

fordítása után.

Clear program memory upon loading a program: Programmemória  törlése  a  program 
letöltésekor.

Clear configuration bits upon loading a program: Konfigurációs  bitek  törlése  a  program 
letöltésekor.

Clear EE data upon loading a program: EEPROM  adatmemória  törlése  a 
program letöltésekor.

Clear user ID upon loading a program: Felhasználói azonosító törlése a program 
letöltésekor.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Hot Keys beállítások:

Hot Key mapping scheme: Gyorsbillentyű séma alkalmazása (*.hot 
kiterjesztéssel magunk is létrehozhatunk 
ilyen sémákat).

Command: A  fejlesztőrendszerben  alkalmazható 
parancsok.

Hot key combination: A  parancshoz  rendelt  gyorsbillentyű 
kombináció.

Hot Key currently in use by: Amennyiben  az  alkalmazni  kívánt 
gyorsbillentyű  már  hozzá  van  rendelve 
egy másik parancshoz, akkor az ebben az 
ablakban megjelenik.

19/102

MPLAB gyorsbillentyűinek beállításai



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Egyéb beállítások:

Clear configuration bits when
clearing program memory: A konfigurációs bitek törlése a program 

memória törlésekor.
Automatically reload files that
were modified outside of the IDE: Az  IDE  rendszer  kinézetének 

módosításakor a fájlok újratöltése.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Project-re vonatkozó beállítások:

Close open source files on project close: A  projekt  bezárásakor  minden  a 
projektben megnyitott fájl bezárása.

Clear output window before build: A kimeneti ablak törlése a fordítás előtt.

Save project before build: Projekt mentése fordítás előtt.

Save files before build: A  fájlok  mentése  fordítás  előtt  (igen, 
nem, rákérdez).

Halt build on first failure: A fordítási folyamat megállítása az első 
hibánál.

Use one-to-one project-workspace model: Egy  projekt,  egy  munkaasztal 
alkalmazása.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Új projekt létrehozása és konfigurálása

a, módszer: A Project → Project Wizard... menüponttal aktiváljuk a projekt varázslót.

A bejelentkező felületen üdvözöl minket a Microchip. A varázsló segítséget nyújt 
számunkra egy új  MPLAB IDE projekt létrehozásához és beállításához. A művelet 
folytatásához kattintsunk a Next (Tovább) gombra!
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Állítsuk  be  a  fejlesztéshez  szükséges  eszköz  típusát,  majd  kattintsunk  a  Next 
(Tovább)  gombra!  (A  Back (Vissza)  gombbal  bármikor  visszaléphetünk  az  előző 
beállító ablakba.)
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Válasszuk ki a fejlesztés során alkalmazni kívánt fordítóeszközt (Active Toolsuite). A 
komponenseit a  Toolsuite Contents ablakban láthatjuk. Az aktív komponens elérési 
útját a Location ablakban módosíthatjuk.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

A következő lépésben két opció közül választhatunk. Létrehozhatunk egy új projektet 
–  ehhez  írjuk  be  a  teljes  elérési  utat  a  Create  New  Project  File ablakba,  vagy 
válasszuk  a  Browse... (Tallózás)  gombot.  Egy  aktív  projekt  beállításait  is 
módosíthatjuk – ehhez használjuk a Reconfigure Active Project ablakot.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

A  negyedik  lépésben  hozzáadhatunk  (Add  >>)  forrásfájlt  a  létrehozandó 
projektünkhöz,  ill.  hozzáadott  fájlt  törölhetünk a projektből  (Remove).  A Remove 
parancs hatására az adott fájl nem lesz a projekt része, de fizikailag természetesen 
nem törlődik.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Az  utolsó  ablakban  egy  összegzést  láthatunk  a  létrehozni  kívánt  projektről. 
Amennyiben minden rendben találunk kattintsunk a Finish (Befejezés) gombra – ha 
valamilyen eltérést tapasztalunk az általunk megadni kívánt paraméterektől, akkor a 
Back (Vissza) gombbal lépjünk vissza az adott beállításhoz, és változtassuk meg azt.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

b, módszer: A Project → New menüpont segítségével hozzunk létre egy projektet.

A felugró ablakba írjuk be a projekt nevét (Project Name) és a kívánt elérési utat 
(Project  Directory),  vagy  a  könnyebb  tájékozódás  végett  válasszuk  a  tallózás 
(Browse...) gombot. Segítséget (Help) kérhetünk a fejlesztőkörnyezettől, amennyiben 
ezt a funkciót választjuk a súgó végigvezet minket egy projekt létrehozásán. Az OK 
gomb megnyomására a projektet az MPLAB létrehozza.

Végezzük el a projekt beállításait manuálisan!

Eszköz kiválasztása: Configure → Select Device...

Fordítóeszköz kiválasztása: Project → Select Language Toolsuite...

Fordítóeszköz elérési útjának módosítása: Project → Set Language Tool Locations...

Forrásfájl hozzáadása az aktív projekthez: Project →Add Files to Project... (Létező fájl)
Add New File to Project... (Új fájl)

Forrásfájl törlése az aktív projektből: Project → Remove File From Project...
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Workspace beállítása

Válasszuk ki a programozni kívánt eszközt: Configure → Select Device...

Válasszunk Debug eszközt: Debug → MPLAB SIM (ez itt csak példa)

Aktiváljunk Programozó készüléket: Programmer → None (ez itt csak példa)

Állítsuk be a konfigurációs biteket: Configure → Configurations bits...

Készítsünk (magunknak tetsző) ablakelrendezést!

Az  általunk  kialakított  ablakelrendezés  (megnyitott  ablakok,  és  azok  pozíciója) 
elmenthető a Window → Create Window Set... menüpont segítségével.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Munkaasztalunk testreszabása nem csak kényelmesebbé teszi a munkánkat, de határozottan 
elősegíti  a  fejlesztést.  Egy  kulturált  és  a  fejlesztő  számára  átlátható  közegben  könnyebben, 
gyorsabban és eredményesebben is tud dolgozni az ember.  Egy fejlesztés napokig hetekig, akár 
hónapokig is tarthat - ez alatt az időszak alatt többször is kénytelenek vagyunk megnyitni bezárni az 
IDE rendszert,  kellemes  ha  minden megnyitáskor  az  előzőleg  meghagyott  rend  alapján  tudunk 
dolgozni. Ezen okok miatt ne sajnáljuk az időt a workspace beállítására!

Forrásfájl(ok) létrehozása, elkészítése, módosítása

Fejlesztésünk  során  mindig  minimum  két  forrással  dolgozzunk!  Az  egyik  legyen  az 
eredetileg megírt szemantikailag – általunk – könnyen értelmezhető – szükség esetén – egyszerűen 
továbbfejleszthető  és  módosítható  kód.  A másik  forrás  az  ún.  optimalizált  kód,  mely  az  adott 
problémára – a megadott paraméterek tükrében - a lehető leghatékonyabb megoldást képviseli. Egy 
optimalizált  kódban történő módosítás  nem csak körülményes,  hanem igen veszélyes is  – ezt  a 
módszert kerüljük, inkább az eredeti forrásba implementáljuk az újításokat, majd helyes működés 
esetén optimalizáljunk újra.

Előfordulhat, hogy kénytelenek vagyunk egy adott problémához több forrást is alkalmazni 
(pl. két, vagy több eszköz szükséges a megoldáshoz, különböző működési paraméterekkel). Ez nem 
okoz különösebb nehézséget, egy projekt tetszőleges számú forrást tartalmazhat.

A források  megírása  során  alkalmazott  programozói  ismereteket  a  II.  számú  melléklet 
tartalmazza.  Itt  csupán  a  szerkesztési  fogásokra  és  a  fejlesztőkörnyezet  által  nyújtott 
segédszolgáltatásokra térünk ki.

Adjunk hozzá egy forrásfájlt a projektünkhöz:

Új fájl hozzáadása: Project → Add New File to Project

Létező fájl hozzáadása: Project → Add Files to Project

Alternatíva: Kattintsunk jobb egérgombbal a projekt ablak Source Files fülére és válasszuk 
az Add Files... opciót!
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

(Amennyiben nem jelent meg a projekt ablak, aktiváljuk a View → Project menüponttal)

Megjegyzés: A View menüpont segítségével többféle információt tudunk megjeleníteni a 
fejlesztőkörnyezetben  felbukkanó ablakok segítségével.  A fejlesztéshez  két 
ablak  elengedhetetlenül  szükséges.  A projekt  ablakot  a  View  →  Project 
menüponttal, míg a kimeneti ablakot a  View → Output menüponttal tudjuk 
aktivizálni. A nézet menüben megjeleníthető további lehetőségek közül csak 
azokat válasszuk ki,  melyekre a fejlesztés adott  fázisában szükségünk van, 
mert a túl sok egymásra halmozott ablak rontja az áttekinthetőséget.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

A forráskód megírása előtt állítsuk be az editor (szövegszerkesztő) tulajdonságait! Válasszuk 
az Edit → Properties... menüpontot (alternatív megoldás: egy szövegfájlban jobb egérgomb, majd 
Properties)!  A  felugró  ablakban  az  IDE  rendszer  beállításaihoz  hasonlóan  több  fül  közül 
választhatunk.

General beállítások:

Use Tabbed Window: Alkalmazása esetén a szövegfájlokat egy 
ablakban külön fülön ábrázolja az editor, 
nem  rendel  minden  fájlhoz  egy  külön 
ablakot  (változtatása  az  IDE  rendszer 
újraindítását igényli).

Protect Read Only files: Amennyiben  be  van  jelölve,  a  csak 
olvasható  fájlokat  nem  tudjuk  az 
editorban  szerkeszteni.  Mellőzésével  a 
csak olvasható fájlok szerkeszthetőek, és 
a változtatások elmenthetőek egy másik 
fájlba.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Enable Source Locator: A GoTo Locator funkció engedélyezése 
(a  projekt  ablakban  egy  szimbólumon 
lévő  jobb  kattintásra  az  adott 
szimbólumra  ugorhatunk  a  C 
forráskódban  –  a  GoTo  Loacator 
segítségével).

Enable Color Printing: Színes nyomtatás engedélyezése.

Find Wrap Messagebox: Amennyiben  be  van  jelölve  az  opció, 
akkor egy szövegdobozzal jelzi,  ha egy 
keresés  művelet  során  elértük  a 
szövegfájl végét.

Alternates <Home> key action: Használata  esetén  a  <Home>  billentyű 
megnyomásakor  a  sorban  lévő  első 
karakter  elé  kerül  a  kurzor.  Mellőzése 
esetén a kurzor mindig a sor elejére kerül 
a <Home> megnyomásakor.

'ASM' File Types beállítások:
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Line Numbers: Sorok  számának  mutatása  a 
forráskódban.

Line Wrap: Sortörés  alkalmazása  (az  ablak 
méretéhez igazított sortörést hajt végre a 
szövegen).

Double Click Toggles Breakpoints: Az  editor  ablakban  dupla  kattintásra 
letesz  egy  töréspontot  az  egérmutató 
által jelölt helyre.

Print Line Numbers: Sorok számának nyomtatása.

Repair Mismatched CR/LF on Save: A  helytelen  kocsi-vissza/soremelés 
javítása mentéskor.

Enable Code Folding – Use ; { and ;}:

Auto Indent: Alkalmazása  esetén  az  új  sor 
automatikusan  annyi  Tab-bal,  és/vagy 
Space-szel  beljebbre  kerül,  mint  az  őt 
megelőző sor.

Tabs (Tabulátorok):
Tab size: Tabulátor mérete (1÷16 karakter).

Insert spaces: Tabulátor  által  alkalmazott  üres  tér 
feltöltése Space karakterekkel.

Keep tabs: „Valódi” tabulátor alkalmazása.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Tooltips beállítások:

Mouseover (Az egér objektum fölé vitele):
Enable Variable Mouseover Values: Az  egérmutatót  a  változó  (szimbólum) 

fölé  mozgatva  egy  felbukkanó  kis 
ablakban láthatjuk annak értékét.

Show Address in Mouseover: Az érték mellet a címet is megjeleníti.

Mouseover Active on Debug: A funkció  csak  a  kód  futtatása  esetén 
alkalmazható (debugoláskor).

Default Type Format (az egérmutató által jelzett érték alapértelmezett formátuma):
Use Watch Preference: A Watch ablak beállításait alkalmazza.

Hex: Hexadecimális  (16-os  számrendszer) 
formátum.

Binary: Bináris (kettes számrendszer) formátum.

Decimal: Decimális  (10-es  számrendszer) 
formátum.

Char: ASCII formátum.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Autocomplete ()
Enable Autocomlete <CTRL+SPACE> Activates: Az  Enable  Source  Locator funkcióval 

együtt  használható.  Engedélyezése 
esetén  a  CTRL+SPACE  kombináció 
segítségével  tudunk  a  projekt  ablakban 
választani a szimbólumok között.

Autolist Struct members . or → Activates: A  struktúra  tagjait  ponttal,  vagy  jobb 
nyíllal jelöli.

Function parameter information ( Activates: A  függvényeket  (amennyiben  előtte 
definiálva  vannak)  bal  zárójel 
segítségével jelöli.

Text beállítások:

Fonts (Betűkészlet):
Select Font: Betűkészlet kiválasztása.

National Language Code Page: A  UNICODE  karakterek  ASCII-ba 
történő átalakításához használt kódtábla.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Colors: A  szövegszerkesztőben  használt 
karakterláncok színeit állíthatjuk be.

Choose Colors: Minden  objektumhoz  (különböző 
számformátumok,  címke,  utasítás, 
direktíva,  megjegyzés,  stb.)  különböző 
színeket rendelhetünk.

Default Colors: Az  alapértelmezett  színkonfiguráció 
visszaállítása.

User Definied Color File: Felhasználó  által  definiált 
színkonfiguráció behívása.

Other beállítások:

Default Window Width: Alapértelmezett  ablakszélesség  (10÷80 
karakter).

Editor and DisAssy Gutter Width: A szövegszerkesztő és a disassembler bal 
oldalsávjának  szélessége  (3÷12 
karakter).
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Line End Ruler Position: Sor végét jelző – függőleges – vonalzó 
karakterpozíciója (0: vonalzó elrejtése).

Ruler Color: A vonalzó színe.

Debugger PC Location – Highlight Full Line: A  Programszámláló  által  mutatott 
utasítássor kiemelése.

Full Line Color: A kiemelés színének beállítása.

Megjegyzés: A szövegszerkesztő (editor) beállításait mindenki a saját igényei szerint állítja 
be. Amennyiben olyan munkaállomáson dolgozunk, ahol mások is használják 
a  fejlesztőkörnyezetet  (pl.  egy  oktatási  intézmény)  –  kerüljük  az 
alapértelmezettől eltérő paraméterek használatát.
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A szövegszerkesztő beállítása után megkezdhetjük a forráskód begépelését.

A forráskód írása közben figyelembe kell vennünk a szintaktikai szabályokat!

A szöveg formai követelményeire vonatkozó szintaktikai szabályok:

Assembly sor felépítése:

CÍMKE →3 MŰVELET → OPERANDUS → ;MEGJEGYZÉS

A programírás  során  a  tabulátorok  használata  ajánlott  az  egyes  oszlopok 
elválasztására – a szöveg jobb tagoltsága érdekében.

A programunk  többségében  címke  nélküli  sorokból  áll,  ezeket  a  szabály 
szerint egy üres karakterrel, vagy tabulátorral beljebb kell kezdenünk. Amennyiben 
nem szeretnénk minden címke nélküli sor elé tabulátort tenni, akkor kezdjük az adott 
utasítást  a  sor  elejétől.  A forráskód(részlet)  begépelése  után  jelöljük  ki  a  címke 
nélküli  sorokat  és  használjuk  az  Edit  →  Advanced  →  Indent  Block  funkciót 
(CTRL+7) – mely egy tabulátorral  beljebb helyezi  a kijelölt  sorokat.  Az  Edit  → 
Advanced → Outdent  Block  funkció (CTRL+8)  egy tabulátorral  kijjebb helyezi  a 
kijelölt sorokat.

Kis- és nagybetűk használata:

Az assembly nyelvben nem kell  semmilyen objektumot  kötelezően nagy-, 
vagy kisbetűvel írni – azonban a fordító különbséget tesz a kis- és nagybetűk között, 
ezért a használatuknak konzekvenseknek kell lennie. Amennyiben egy szimbólumot 
nagybetűvel  definiáltunk,  csak  nagybetűvel  tudunk  rá  hivatkozni  –  és  ez 
természetesen  igaz  kisbetűvel  is.  Az  SFR (Special  Function  Register  –  Speciális 
funkciójú regiszterek) megadása a gyári include fájlban nagybetűvel történt – ezért 
ezeket  mindenképpen nagybetűvel kell  alkalmaznunk a forrásban is.  Minden más 
általunk  megadott  szimbólum  már  fakultatív.  A  műveletek,  direktívák  kis  és 
nagybetűvel  egyaránt  elfogadhatóak.  Ha  nem  szeretnénk  ezzel  a  problémával 
foglalkozni,  akkor  az  egész  forráskódot  (a  megjegyzés  kivételével)  írjuk 
nagybetűvel. Az MPLAB szövegszerkesztője lehetőséget nyújt kijelölt szöveg kis-, 
vagy nagybetűkké alakítására.

Nagybetűs  átalakításhoz  használjuk  az  Edit  →  Advanced  →  Uppercase 
menüpontot (CTRL+3)

Kisbetűs  átalakításhoz  használjuk  az  Edit  →  Advanced  →  Lowercase 
menüpontot (CTRL+4)

3 Tabulátor(ok), vagy Space karakter(ek)
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Megjegyzések használata:

Egy megjegyzés  (komment)  az  assembly nyelvben mindig a ';'  karakterrel 
kezdődik.  Természetesen teljes  sorok is  lehetnek  megjegyzések – általában egyes 
programrészek, rutinok előtt (bonyolultságtól függően) 5-10 sorban érdemes leírni a 
funkcionális  működést.  Mindemellett  előfordul,  hogy  egyes  rutinokat, 
programrészeket ún. kikommentezünk a programból, mert vagy nem vagyunk még 
biztosak a működésükben, vagy olyan funkciót valósítanak meg, melyekre az adott 
fejlesztési  résznél  nincs  szükségünk4.  Nagyobb  lélegzetű  megjegyzés  esetén  nem 
szükséges minden sort ';'-al kezdenünk. Az Edit → Advanced → Comment Block  
(CTLR+6) segítségével  a  kijelölt  szöveg  minden  sora  elé  ';'  karakter  kerül. 
Amennyiben  megjegyzésként  írt  sorokat  szeretnénk  futtatható  kóddá  tenni 
használjuk az Edit → Advanced → Uncomment Block funkciót (CTLR+6)

Az editor formázási lehetőségeit az Edit menüből érhetjük el:

Visszavonás: Az Edit → Undo menüponttal érhető el a szolgáltatás (Gyorsbillentyű: 
CTRL+Z).  Az  utolsó  –  a  szövegszerkesztőben  végzett  –  művelet 
visszavonása.

Újra: Az Edit → Redo menüponttal érhető el a szolgáltatás (Gyorsbillentyű: 
CTRL+Y).  Az utolsó – a  szövegszerkesztőben végzett  –  visszavont 
művelet újbóli végrehajtása.

Kivágás: Az Edit → Cut menüponttal érhető el a szolgáltatás (Gyorsbillentyű: 
CTRL+X). Kijelölt szöveget helyezhetünk át a vágólapra (a szöveg az 
eredeti helyéről törlődik).

Másolás: Az Edit → Copy menüponttal érhető el a szolgáltatás (Gyorsbillentyű: 
CTRL+C). Kijelölt szöveget másolhatunk át a vágólapra (a szöveg az 
eredeti helyéről nem törlődik).

Beillesztés: Az Edit → Paste menüponttal érhető el a szolgáltatás (Gyorsbillentyű: 
CTRL+V). A vágólap tartalmát beilleszti a kurzor  által kijelölt helyre.

Törlés: Az  Edit  →  Delete menüponttal  érhető  el  a  szolgáltatás 
(Gyorsbillentyű: DEL). Kijelölt szöveget törölhetünk.

Teljes szöveg kijelölése: Az  Edit  →  Select  All menüponttal  érhető  el  a  szolgáltatás 
(Gyorsbillentyű:  CTRL+A).  Az  aktív  fájlban  lévő  teljes  szöveget 
kijelöli.

Keresés: Az  Edit  →  Find... menüponttal  érhető  el  a  szolgáltatás 
(Gyorsbillentyű:  CTRL+F).  Az  aktív  fájlban  kereshetünk  rá  egy 
általunk megadott kulcsszóra.

4 A II. számú melléklet tárgyalja a feltételes fordítás lehetőségét. Több programozó feltételes fordítás helyett a kézi 
megjegyzéssé tételt alkalmazza a könnyebb olvashatóság érdekében.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Következő keresése: Az  Edit  →  Find  Next menüponttal  érhető  el  a  szolgáltatás 
(Gyorsbillentyű: F3). Az utoljára megadott kulcsszó további keresése 
a szövegben.

Keresés fájlokban: Az  Edit  →  Find  in  Files... menüponttal  érhető  el  a  szolgáltatás 
(Gyorsbillentyű: CTRL+SHIFT+F). Több fájlban is kereshetünk adott 
kulcsszóra.  A keresés  eredményét  a  kimeneti  ablakban  tekinthetjük 
meg.

Csere: Az  Edit  →  Replace... menüponttal  érhető  el  a  szolgáltatás 
(Gyorsbillentyű:  CTRL+H).  Adott   kulcsszóra  történő  keresés  a 
szövegben és – opcionálisan – egy általunk megadott karakterlánccal 
történő kicserélése.

Ugrás: Az  Edit  →  Go  To... menüponttal  érhető  el  a  szolgáltatás 
(Gyorsbillentyű: CTRL+G). Adott sorra, vagy címkére lévő ugrást tesz 
lehetővé.

Könyvjelzők használata:

A  programunk  egyes  részeit  a  későbbi  tájékozódás  végett  elláthatjuk 
könyvjelzőkkel.

Könyvjelzők hozzáadása: Edit → Bookmarks → Toggle Bookmark 
(CTRL+K). A kurzor által kijelölt helyre 
letesz egy könyvjelzőt.

Ugrás a következő könyvjelzőre: Edit  → Bookmarks  → Next  Bookmark 
(CTRL+L).  Az  aktuális  helyről  a 
következő könyvjelzőre történő ugrás.

Ugrás az előző könyvjelzőre: Edit  →  Bookmarks  →  Previous 
Bookmark  (CTRL+J).  Az  aktuális 
helyről  az  előző  könyvjelzőre  történő 
ugrás.

Az összes könyvjelző törlése: Edit  →  Bookmarks  →  Clear  All  
Bookmarks. Az aktuális szövegfájlban az 
összes könyvjelző törlése.

 Az include fájlokat az asm forrásfájlhoz hasonlóan készíthetjük el, és adhatjuk hozzá a 
projektünkhöz. Assembly nyelv esetén inc, C nyelv esetén h kiterjesztést kapnak.
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A források átolvasása, elemzése, ellenőrzése (előzetes szintaktikai és 
logikai analízis)

Sajátos  emberi  tulajdonság,  hogy  másokban  hamarabb  látjuk  meg  a  hibát  mint  saját 
magunkban. Sajnálatos módon ez igaz a programokra is. Az általunk megírt kód olvasása során az 
agyunk általában már jóval a ténylegesen látott gondolatmenet előtt jár, és hajlamos az apróbb hibák 
felett  átsiklani.  Nagy  segítségünkre  lehet  egy  programozásban  jártas  barátunk,  akivel  együtt 
elemezzük a forrást. Ebben az esetben nem tekinthetünk adott kódsorozatot evidenciának – mindent 
kénytelenek  vagyunk  érthetően  logikailag  elmagyarázni  és  bizonyítani.  Amennyiben  egyedül 
kényszerülünk  programunk  analizálására,  ezt  mindig  fokozott  figyelemmel  tegyük.  Próbáljunk 
elvonatkoztatni a helyzettől, és vizsgáljuk úgy a kódot, mintha azt egy előadás formájában kellene 
ismertetnünk egy szkeptikus hallgatósággal.

Az ellenőrzés során használjuk a könyvjelzőket,  valamint az  Edit  → Go To... funkciót a 
könnyebb olvashatóság érdekében.

Fordítás (szintaktikai ellenőrzés):

A PIC mikrovezérlők esetén Compilert5 használunk a forráskód mikroszámítógép számára is 
emészthetővé tételére. A Compiler a fordítás során ellenőrzi, hogy az általunk írt forráskód megfelel 
e a szintaktikai (nyelvi) követelményeknek.

Amennyiben projekt rendszerben dolgozunk a fordításra használjuk a build parancsot:

• Project → Build All
• CTLR+F10
• Ikonként:

A fordítás előtt bizonyosodjunk meg, hogy helyes build konfiguráció6 van beállítva!

Előfordulhat  olyan  eset,  hogy a  projektünk  beállításait  nem szeretnénk  a  fordítás  során 
alkalmazni,  vagy  nem  tartozik  projekt  a  forráskódhoz.  A  Project  →  Quickbuild  menüopció 
segítségével le tudjuk fordítani az aktív forrásfájlt.

5 Compiler (fordító): a forráskódot egy fordító segítségével a számítógép számára értelmezhető kóddá alakítjuk. 
Interpreter (értelmező): a forráskódot futási időben értelmezzük.

6 Project → Build Configurations
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Hibakeresés (Szimulátor; Debugger; Emulátor; Éles teszt):

Szimulátor: olyan (szoftveres) eszköz, melyben a valós készülékünket egy matematikai 
modell  helyettesíti.  A  szimulációs  eljárás  egyszerűbb  algoritmusok 
működőképességének  kiértékelésére,  a  processzor  matematikai 
műveletvégzésének  ellenőrzése  alkalmas.  Nem  vizsgálható  vele  olyan 
fejlesztés, melyben kulcsszerepet kapnak egyes fizikai sajátosságok. Gyártó-
specifikus perifériák paraméterei (írási-olvasási idő; válasz idő; késleltetések; 
buszsebesség; stb.) eltérhetnek a modelltől.

Debugger: a debugger egy hibakereső eszköz - logikailag a szimuláció és az emuláció 
között helyezkedik el. A Mircochip ICD2 debuggere 5 ponton csatlakozik a 
mikrovezérlőhöz, míg egy emulátor POD-ja a mikrovezérlő/mikroprocesszor 
helyére kerül  -  fizikailag helyettesítve azt.  A debuggernek szüksége van a 
mikrovezérlő belső erőforrásaira, valamint órajelforrásra is. A hibakeresővel 
végzett  ellenőrzés  során  nem a  valós  program fut,  hanem egy ún.  debug 
program.  Az  ICD2  -vel  ellenőrzött  programban  csak  egyszerű  törésponti 
feltételeket adhatunk meg és ezek száma is erősen korlátozott – szemben egy 
emulátorral.  Összefoglalva:  a  debugger  közelebb visz a  valós  működéshez 
mint a szimuláció, de kevesebb lehetőséggel rendelkezik mint egy emulátor. 
A  debugger  előnye  az  árában  mutatkozik  meg,  összehasonlítva  egy 
emulátorral kb. tizedannyi a költség.

Emulátor: A vizsgálandó programozható eszközt egy másik eszközzel helyettesíti, mely 
minden  a  működés  szempontjából  lényeges  paraméterben  megegyezik  az 
eredeti eszközzel. Az emulátorral szemben támasztott követelmények között 
szerepel,  hogy  működés  közben  teljesen  úgy  viselkedjen,  mintha  az 
emulálandó  eszközt  használnánk  –  azonban  lehetőséget  nyújtson  olyan 
vizsgálatok  elvégzésére,  melyeket  az  eredeti  eszközzel  nem,  vagy  csak 
nagyon költségigényes módon tudnánk végrehajtani. Egy emulátorral végzett 
vizsgálat  során  a  processzort  meg  tudjuk  állítani,  a  regiszterek  értékét  ki 
tudjuk  olvasni,  és  akár  módosíthatjuk  is  azokat.  Összetett,  bonyolult 
törésponti feltételeket adhatunk meg – gyakorlatilag korlátlan számban. Egy 
jó minőségű emulátor teljes mértékben képes kiváltani a logikai analizátort – 
nagy költségeket megtakarítva a fejlesztés során.

Éles teszt: az  eljárás  során  eszközünket  valós  körülmények  között  vizsgáljuk. 
Amennyiben nem mi készítettük a hardvert az alkalmazáshoz emlékezzünk a 
programozók  legfontosabb  igazságára:  „Ez  biztos  valami  hardverhiba”. 
Mielőtt  a  mikroprocesszoros  rendszert  teszteljük  ellenőrizzük  a 
hardverkialakítást  mind  elméleti,  mind  gyakorlati  szinten.  Az  analízis 
funkcionális teszttel kezdődik. Vizsgáljuk meg, hogy a rendszer teljesíti-e a 
specifikációban megfogalmazott igényeket. Hiba bekövetkezése esetén több 
lehetőség  is  rendelkezésünkre  áll.  Elemezhetjük  manuálisan  a  kódot, 
használhatunk  szimulációs  és  emulációs  eljárásokat  a  hiba  okának 
felderítésére, valamint elvégezhetjük az áramkör bemérését.
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Általánosan  használatos  műszerpark  egy  mikrovezérlős  rendszer 
vizsgálatához:

• Digitális multiméter
• Oszcilloszkóp (lehetőleg digitális)
• Logikai analizátor
• Végrehajtás analizátor

Utóbbi két eszközt – magas  ára miatt – ritkán használjuk a fejlesztésben. 
Általában  valamilyen  szoftveres  eljárással  (szimulációs  környezettel) 
próbáljuk helyettesíteni funkcióikat.

 
Megjegyzés: A  mikrovezérlők  fejlesztéséhez  nem  feltétlenül  szükséges  szimulátor, 

hibakereső, emulátor, ill. költséges műszerpark – bár a gyakorlatban ennek 
megléte  nagyban  segíti  a  munkánkat.  Egy  megfelelő  hardver  és 
szoftverismerettel rendelkező szakember ezen eszközök nélkül is képes nagy 
volumenű  fejlesztések  végrehajtására  –  a  megfelelő  szakmai  tapasztalat 
megszerzése után, melyet csak sok gyakorlással lehet elsajátítani.
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Szimuláció az MPLAB IDE fejlesztőrendszerben

Válasszuk  ki  hibakereső  eszköznek  az  MPLAB  SIM szimulátor  összetevőt!
Debugger → Select Tool → MPLAB SIM 

A  szimuláció  megkezdése  előtt  állítsuk  be  a  szimuláció  tulajdonságait!
Debugger → Settings...

Processor Frequency: A processzor órajele.

Units: Mértékegység.

Trace Options (Nyomkövetés beállításai):
Trace All: Minden utasítás nyomkövetése.

Break on Trace Buffer Full: Nyomkövetés  megállítása,  ha  a  buffer 
megtelik.

Buffer Size: Buffer mérete.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Core (including stack): Processzormag  beleértve  a  vermet  is. 
Veszély,  és/vagy  hiba  esetén 
lehetőségünk  van  riportot  készíteni, 
figyelmen  kívül  hagyni  a  problémát, 
valamint megállítani a processzort.

Peripheral: Perifériákra vonatkozó beállítás. Veszély, 
és/vagy  hiba  esetén  lehetőségünk  van 
riportot  készíteni,  figyelmen  kívül 
hagyni a problémát, valamint megállítani 
a processzort.

WDT Timeout: WDT túlcsordulás.  Veszély  esetén 
lehetőségünk  van  megállítani  a 
processzort, megállítani a processzort és 
„veszély”  üzenetet  küldeni  a 
felhasználónak, reszetelni a processzort.

WDT Period (No pre/post-scalers): WDT ciklusideje.
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SCL: A  szimulátor  vezérlőnyelvéhez  tartozó 
beállítások. Veszély, és/vagy hiba esetén 
lehetőségünk  van  riportot  készíteni, 
figyelmen  kívül  hagyni  a  problémát, 
valamint megállítani a processzort.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Enable Uart1 IO: Univerzális  aszinkron  port 
engedélyezése.

Input File: A  soros  porton  fogadott  információt 
tartalmazó fájl.

Rewind Input: Fogadott fájl olvasása az elejétől.

Output (Kimenet):
Window: A  kimenet  (adás)  megjelenítése 

ablakban.

File: A kimenet  (adás) megjelenítése fájlban.
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Disabled: Coverage funkció letiltva.

Enabled/Reset on POR: Kódlefedés  funkció  engedélyezve, 
Power  up  Reset (bekapcsolási  reszet) 
törli a Coverage jelzéseket.

Enabled/Reset on RUN: Kódlefedés funkció engedélyezve,  RUN 
(futtatás) törli a Coverage jelzéseket.

Enabled/Manual Reset: Kódlefedés  funkció  engedélyezve, 
felhasználó törli a Coverage jelzéseket.

Enable Output to File: A  hibakeresés  során  létrejött 
kódlefedéssel  kapcsolatos  információk 
fájlba mentése.
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Animate step time: Animate  (lassú  futtatás)  utasítás 
időközének beállítása (ms-os lépésekben 
állítható).

Realtime watch (Valósidejű futtatás során a Watch ablak működése):

Enable Realtime watch updates: Valós  idejű  futtatás  során  a  „figyelő” 
ablak  frissítése  (100ms-os  lépésekben 
állítható).
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Device: A  hibakeresés  során  alkalmazott 
mikrovezérlő típusa.

A  fehér  ablakban  láthatjuk  az  adott  mikrovezérlő  típusra  vonatkozó  korlátozásokat 
címszavakban  –  ha  erről  több  információt  szeretnénk  megtudni  kattintsunk  a  Details 
(részletek) gombra.
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Korlátozások a szimuláció terén az adott  
mikrovezérlőtípusra vonatkozóan



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Az MPLAB szimulátora többféle reszetet is elő tud állítani:

Debugger → Reset → MCLR Reset: Master Clear lábon történő H-L átmenet.
Debugger → Reset → Watchdog Timer Reset: WDT túlcsordulása.
Debugger → Reset → Brown Out Reset: Alacsony tápfeszültségszint.
Debugger → Reset → Processor Reset: Bekapcsolási reszet.

A szimulációt mindig bekapcsolási  reszet feltétellel  kezdjük meg. A későbbiek folyamán 
megadhatunk más reszetet előidéző eseményt is a programunk működésének tanulmányozására.

A szimuláció  elvégzése  során  a  következőképpen  utasíthatjuk  a  processzort  a  művelet-
végrehajtásra:

Debugger → Run (F9): Valós  idejű  futtatás,  a  processzor  a  megadott  órajel  által 
meghatározott ciklusidő szerint hajtja végre az utasításokat.

Debugger → Animate: A  processzor  a  Debugger  →  Settings... menüpont 
Animation/Realtime  Update fülében  beállított  léptetési 
időközönként hajtja végre az utasításokat.

Debugger → Halt (F5): A processzor utasítás-végrehajtásának megállítása.
Debugger → Step Into (F7): Egy utasítás végrehajtása.
Debugger → Step Over (F8): Egy utasítás végrehajtása, a szubrutinok kihagyásával.
Debugger → Step Out: Szubrutinból való kilépés.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

A rendelkezésünkre álló gerjesztő, és vizsgálati eszközök:

Debugger → StopWatch: Időmérő  eszköz  az  utasítások,  időzítések,  rutinok, 
programrészek végrehajtási idejének meghatározására.

Synch: Stopper  szinkronizálása  a  teljes  szimulációs  időhöz
(Stopwatch = Total Simulated).

Zero: Stopper nullázása

Instruction Cycles: A legutóbbi nullázás óta (Stopwatch) és a legutóbbi reszet óta 
(Total Simulated) végrehajtott gépi ciklusok száma

Time: A legutóbbi nullázás óta (Stopwatch) és a legutóbbi reszet óta 
(Total Simulated) eltelt idő μs-ban.

Processor Frequency: Processzor  órajele  (itt  csak  olvasható,  állítani  a
Debugger → Settings... menüpont Osc/Trace fülében tudjuk)

Debugger → Breakpoints...: Töréspontok  hozzáadása  a  forráskódhoz.  A  töréspontok 
segítségével egyszerűsíthetjük a hibakeresést – ezen kitüntetett 
pontoknál a processzor abbahagyja az utasításvégrehajtást, és 
megvizsgálhatjuk a memóriarekeszek tartalmát. Töréspontokat 
adhatunk  meg  a  forráskód  adott  sorában  történő  kettős 
kattintással is.

Debugger → Complex Breakpoint: Összetett  töréspontok megadására  is  lehetőségünk van  (több 
feltétel egyidejű, vagy adott sorrendben történő teljesülése).

Debugger → Profil: Egy  táblázatban  megtekinthetjük  a  debugolás  során 
végrehajtott utasításokról szóló statisztikai információkat.
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Időmérő eszköz beállítása



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Debugger → Stimulus: Gerjesztő  jelek  hozzáadása  a  mikrovezérlő  lábaihoz, 
regiszterek feltöltése adott értékekkel.

Fire: Művelet elvégzése.

Pin/SFR: Láb, vagy speciális funkciójú regiszter.

Action: Művelet (magas szint, alacsony szint, szintváltás, impulzus).

Width: Amennyiben impulzust választottunk műveletként, itt adhatjuk 
meg annak hosszát.

Units: Az impulzushossz mértékegysége.

Comments/Messages: Megjegyzés (opcionális).
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Aszinkron gerjesztőjel hozzáadása a mikrovezérlő lábaihoz, vagy speciális funkciójú 
regisztereihez



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Time Units: Időegység.

Repeat: Ismétlődés.

After Adott időegységgel később.

Restart at: Újraindítás.

Click here to Add Signals: Regiszter, vagy láb hozzáadása.
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Regiszterhez, vagy lábhoz rendelt szinkron jel



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Define Triggers: A feltétel teljesülése esetén bekövetkezett esemény.

Enable: A sorban lévő esemény engedélyezése.

Conditions: Feltétel neve (válasszunk a listából).

Type: Esemény típusa (egyszer, folytatólagos, ismétlődő)

Re-Arm Delay: Amennyiben az esemény folytatólagos, akkor megadhatjuk az 
időközt.

Click here to Add Signals: Regiszterek, lábak hozzáadása.

Define Conditions: Feltétel kifejtése.

Condition: Feltétel neve.

When Changed: Feltétel megadása (pl. SFR PORTB = A5)

Wait: Várakozás a feltétel bekövetkezte után.

Comments: Megjegyzés.
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Összetett szinkron jelek generálása



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Label: Név (opcionális).

Pin: A négyszögjelet az itt megadott lábra adjuk.

Initial: Reszet esetén ezen a szinten van a gerjesztőjel.

Low Cyc: Alacsony szint ideje gépi ciklusban.

High Cyc: Magas szint ideje gépi ciklusban.

Begin: A négyszögjelet ettől a feltételtől kezdjük el generálni.

Always: Mindig (a futtatás kezdetétől).

PC: A PC adott értékétől.

Cycle: Adott gépi ciklus után.

Pin: Egy láb alacsony, vagy magas szintje.

End: A négyszögjel ebben az esetben szűnik meg.

Never: Soha.

57/102

Négyszögjel gerjesztés hozzárendelése a mikrovezérlő lábaihoz



Programfejlesztés az MPLAB fejlesztőkörnyezetben

PC: A PC adott értékétől.

Cycle: Adott gépi ciklus után.

Pin: Egy láb alacsony, vagy magas szintje.

Comments: Megjegyzés (opcionális).

Label: Név megadása (opcionális).

Reg/Var: Regiszter vagy változó szimbóluma

Trigger: Regiszterfeltöltés indításának kiválasztása. Lehetőségünk van a 
feltöltést  a  programszámláló  adott  értékétől  indítani 
(amennyiben  a  regiszterhez  tartozó  periféria  nincs 
engedélyezve),  vagy  a  periféria  implementálásától  is 
indíthatunk (Demand).

PC Value: Ha a Trigger pontban a PC-t adtuk meg indítási feltételként ide 
írjuk be az értékét.
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Regiszter értékének megadása bemeneti fájl alapján



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Width: Ha a Trigger pontban a PC-t adtuk meg indítási feltételként, itt 
találjuk annak adatszélességét bájt nagyságrendben.

Data Filename: A regiszter értékeit a megadott fájlból tölti be.

Wrap: Amennyiben a fájl végére értünk kezdhetjük az elejéről (YES), 
vagy az utolsó értéket használjuk feltöltésre (NO)

Format: Bemeneti fájl formátuma.

Comments: Megjegyzés (opcionális, nem befolyásolja a működést).

Label: Név megadása (opcionális).

Reg/Var: Regiszter, vagy változó szimbóluma.

Trigger: Monitorozás  indításának  kiválasztása.  Lehetőségünk  van  a 
nyomkövetést  a  programszámláló  adott  értékétől  indítani 
(amennyiben  a  regiszterhez  tartozó  periféria  nincs 
engedélyezve),  vagy  a  periféria  implementálásától  is 
indíthatunk (Demand).
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Regiszterváltozások nyomonkövetése



Programfejlesztés az MPLAB fejlesztőkörnyezetben

PC Value: Ha a Trigger pontban a PC-t adtuk meg indítási feltételként ide 
írjuk be az értékét.

Width: Ha a Trigger pontban a PC-t adtuk meg indítási feltételként, itt 
találjuk annak adatszélességét bájt nagyságrendben.

Trace Filename: A regiszter értékének változásait a megadott fájlba menti.

Format: A nyomkövetés során keletkezett fájl formátuma.

Comments: Megjegyzés (opcionális, nem befolyásolja a működést).
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

View → CPU Registers: A  PIC32MX mikrovezérlők  speciális  funkciójú  regisztereit 
jeleníti meg.

View → Call Stack: 16 és 32 bites eszközöknél a  C nyelven írt kódban lévő hívó 
(CALL)  és  ugró  (GOTO)  utasításokat  tekinthetjük  meg  a 
felbukkanó ablakban – ennek segítségével optimalizálhatjuk a 
magasszintű  kódot,  valamint  figyelemmel  kísérhetjük  a 
processzor  utasítás-végrehajtását.  Assembly  kód  esetén  az 
opció nem használható.

View → Disassembly Listing: Megjeleníti  a  forráskódunk  gépi  kódját  –  így  könnyedén 
megtalálhatjuk a helytelen címzéseket, ugrásokat a hibakeresés 
során.

View → EEPROM: Megjeleníti  az  EEPROM adatmemóriát  (amennyiben  olyan 
eszköz van kiválasztva, mely tartalmaz belső EEPROM-ot). Az 
ablak a processzor megállításakor, vagy az EEPROM regiszter 
értékének változásakor frissül.

Az  adott  memóriarekeszre  kattintva  manuálisan  is  módosíthatjuk  a  tartalmat.  Az 
adatmegjelenítés alapértelmezett formátuma hexadecimális és ASCII.
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EEPROM adatmemória megjelenítése



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Az ablakban az egér jobb gombjára kattintva a következő opciók közül választhatunk:

Close: Ablak bezárása.

Find...: Keresés az EEPROM adatmemóriában.

Find Next: Következő keresése.

Go To... Adott címre ugrás az EEPROM adatmemóriában.

Import Table... Táblázat importálása (*.MCH).

Export Table...: Táblázat exportálása későbbi felhasználásra (*.MCH).
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EEPROM 
adatmemóriával 

kapcsolatos  
lehetőségek



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Fill Memory...: Memória feltöltése adott érté(ke)kkel.

Start Address: Kezdőcím.

End Address: Végcím.

Data: Adat.

Data Radix: Az adat számformátuma.

Use Data As: Adatfeltöltés módja.

Fill Value: A Data helyére beírt értékkel a kezdőcímtől a végcímig 
való feltöltés.

Sequence Start: A kezdőcímre 0 beírása,  majd a végcímig a beírandó 
érték eggyel való ciklikus növelése.

Randomize Start: A kezdőcímtől  a  végcímig  véletlen  értékekkel  való 
feltöltés.

Retain Address Range: Kezdő és végcím megtartása bezárás után.

Write: A beállított konfigurációval az írás megkezdése.
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EEPROM adatmemória 
feltöltése



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Output To fájl...: Ablakinformáció mentése text fájlba.

Print...: Nyomtatás.

Refresh: Kézi frissítés.

Help: Segítség  kérése.  Az  MPLAB  IDE  help EEPROM ablakra 
vonatkozó részét nyitja meg a program.

Properties: A megjelenített  ablak tulajdonságait  állíthatjuk be (A  Debug 
ablakokban használt szín, és betűkészlet).

View → File Registers: A  mikrovezérlő  összes  fájlregiszterének  mutatása  (teljes 
adatmemória: GPR; SFR).

A megjelenítés lehet tisztán hexadecimális (lásd fent), vagy szimbolikus (lásd lent).
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A mikrovezérlő adatmemóriája hexadecimális formátumban

A mikrovezérlő adatmemóriája szimbólikus jelöléssel



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Az ablakban történő jobb egérgombbal való kattintással további opciókat érünk el:

Close: Ablak bezárása.

Full Memory Update: Teljes adatmemória frissítése

Find...: Keresés az adatmemóriában.

Find Next: Következő keresése.

Go To... Adott címre ugrás az adatmemóriában.

Import Table... Táblázat importálása (*.MCH).

Export Table...: Táblázat exportálása későbbi felhasználásra (*.MCH).
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Az adatmemória 
ablakhoz tartozó 

beállítások és opciók



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Fill Registers: Fájlregiszter-tartomány feltöltése.

Start Address: Kezdőcím.

End Address: Végcím.

Data: Adat.

Data Radix: Adatformátum (hexadecimális, vagy decimális).

Use Data As: Adatfeltöltés módja

Fill Value: A Data helyén álló értékkel töltjük fel az adatmemóriát 
a kezdőcímtől a végcímig.

Sequence Start: A kezdőcímre  nullát  írunk,  majd  a  végcímig  mindig 
eggyel nagyobb értéket töltünk az adatmemóriába.

Randomize Data: A kezdőcímtől a végcímig terjedő regisztertartományt 
véletlenszerű értékekkel töltjük fel.

Retain Address Range: A kezdő és végcím értékének megtartása bezárás után.

Write: A  beállított  konfiguráció  alapján  az  adatmemória 
feltöltése
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Adatmemória feltöltése



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Output To fájl...: Ablakinformáció mentése text fájlba.

Print...: Nyomtatás.

Refresh: Manuális frissítés.

Help: Segítség  kérése.  Az  MPLAB  IDE  help  fájlregiszter  ablakra 
vonatkozó részét nyitja meg a program.

Properties: A megjelenítés tulajdonságait állíthatjuk be.

SFR Change: Lehetőségünk  van  külön  színt  rendelni  a  speciális 
funkciójú regiszterek hátteréhez.

Unallocated Memory: Lehetőségünk van külön színt rendelni a nem lefoglalt 
regisztertartomány hátteréhez.
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Regiszterek háttérszínének beállítása



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Az ablakban látni kívánt oszlopokat jelöljük be a fenti felsorolásból (kattinthatunk a 
jelölőnégyzetbe, vagy használhatjuk a  Hide  (elrejt),  Show  (mutat) gombokat is). A 
Move  Up  és  a  Move  Down  gombokkal  tudjuk  az  alapértelmezett  sorrendet 
megváltoztatni.  A  Defaults gomb segítségével  visszaállíthatjuk  az  alapértelmezett 
megjelenítést.
Az itt  bemutatottakon kívül lehetőségünk van még a  Properties pontban a  Debug 
ablakokban használt szín, és betűkészlet állítására.

View → Flash Data: Megjeleníti a mikrovezérlő Flash adatmemóriáját (amennyiben 
olyan  eszköz  van  kiválasztva,  mely  tartalmazza).  A  Flash 
adatmemóriát  ne  tévesszük  össze  az  EEPROM-mal,  vagy  a 
belső regisztertartománnyal.

View → Hardware Stack: Megjeleníti a belső hardveres vermet. Ezen ablak segítségével 
nyomon  követhetjük  a  szubrutinhívások  során  keletkezett 
automatikus  veremírásokat,  és  -olvasásokat.  Nagy  segítség 
lehet  verem  túlcsordulás  (stack  overflow)  és  verem 
alulcsordulás (stack underflow) felderítésére.

View → LCD Pixel: Egyes  mikrovezérlők  tartalmaznak  LCD  meghajtó  drivert. 
Amennyiben  ilyen  eszközre  fejlesztünk,  megjeleníthetjük  a 
programunk által kirajzolt LCD pixeleket.
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Az ablakban ábrázolandó oszlopok



Programfejlesztés az MPLAB fejlesztőkörnyezetben

A fenti ablakban megtaláljuk az LCD driverhez tartozó regisztereket – azok értékével együtt, 
valamint  egy szimbolikus  megjelenítő  egységet.  Alapértelmezetten az LCD driver  tiltása 
esetén minden négyzet szürke. Az LCD driver engedélyezése esetén fehér négyzet jelzi a 
logikai nulla, sötétszürke négyzet a logikai egy értéket.

Az ablakban történő jobb egérgombbal való kattintással további opciókat érünk el:

Close: Ablak bezárása.
Bitfield Mouseover: Ha  engedélyezve  van  és  az  egeret  valamely  regiszter 

szimbóluma fölé mozgatjuk megjeleníti a regiszterhez tartozó 
bitmezőt  a  felbukkanó  ablakban  (a  szabványos 
bitszimbólumokat, azok helyiértékét, és logikai értékét).
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LCD pixel ablak

LCD driver ablak 
opciói



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Find...: Keresés az LCD driver regiszterei között.

Find Next: Következő keresése.

Go To... Adott címre ugrás az LCD driver regisztertartományában.

Output To fájl...: Ablakinformáció mentése text fájlba.

Print...: Nyomtatás.

Refresh: Kézi frissítés.

Help: Segítség  kérése.  Az  MPLAB  IDE help  LCD  Pixel ablakra 
vonatkozó részét nyitja meg a program.

Properties: A megjelenítés tulajdonságait állíthatjuk be (mutatott oszlopok, 
és színek).

View → Locals: Magasszintű (C, BASIC) nyelven írt programunkban tudjuk a 
változókat monitorozni.

View → Memory: PIC32MX eszköznél az ablak megmutatja a program- és/vagy 
az adatmemória-tartomány elhelyezkedését.

View → Program Memory: Egy ablakban megjeleníthetjük a programmemória tartalmát.

Opcode Hex: Csak hexadecimális formátum.

Gépi kód: A hexadecimális  formátum  mellett  megjeleníti  az  assembly 
kódot is, de nem tartalmaz címkemezőt.

Symbolic: A hexadecimális  kód mellett  láthatjuk az assembly kódot is, 
címkemezővel együtt.
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A programmemóriát reprezentáló ablak



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Az ablakban történő jobb egérgombbal való kattintással további opciókat érünk el:

Close: Ablak bezárása.

Breakpoints: Töréspontok  engedélyezése,  tiltása,  törlése  –  a  machine és 
symbolic fül esetén adott töréspontokat is tudunk engedélyezni, 
tiltani, törölni.

Run To Cursor: A programmemóriában  a  kurzor  által  kijelölt  helyig  történő 
futtatás.

Set PC at Cursor: A  kurzor  által  mutatott  memóriacím  betöltése  a 
programszámlálóba (ugrás a kurzor által mutatott helyre).

Center Debug Location: A programmemória ablakában a hibakeresés aktuális  helyére 
történő ugrás.

Cross Tab Tracking: A  programszámláló  aktuális  értékének,  vagy  az  aktuális 
címnek  a  függvényében  tudunk  nyomkövetést  alkalmazni. 
Alapértelmezetten ki van kapcsolva.

Find...: Keresés a programmemóriában.

Find Next: Következő keresése.
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Programmemória 
ablak opciói



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Go To... Adott címre, vagy címkére ugrás a programmemóriában.

Import Table... Táblázat importálása (*.MCH).

Export Table...: Táblázat exportálása későbbi felhasználásra (*.MCH).

Fill Memory...: Programmemória feltöltése. Használata megegyezik az 
EEPROM adatmemória ablaknál leírtakkal.

Output To fájl...: Ablakinformáció mentése text fájlba.

Print...: Nyomtatás.

Refresh: Kézi frissítés.

Help: Segítség  kérése.  Az  MPLAB  IDE  help  Program  Memory 
ablakra vonatkozó részét nyitja meg a program.

Properties: A megjelenítés tulajdonságait állíthatjuk be (mutatott oszlopok, 
és színek).

View → Special Function Registers:Speciális  funkciójú  regiszterek  megjelenítése.  Az  SFR az 
adatmemória kitüntetett része. Ebben a regisztertartományban 
található a mikroprocesszor (akkumulátor,  STATUS, stb.) és a 
perifériák  (TRISB,  PORTA,  stb.)  működését  befolyásoló 
regiszterek.

A  felbukkanó  ablakban  láthatjuk  az  SFR regiszterek  címeit,  neveit  és  értékeit.  A 
megjelenítendő oszlopokat beállíthatjuk a Properties fülnél (jobb egérgomb).
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Az ablakban történő jobb egérgombbal való kattintással további opciókat érünk el:

Close: Ablak bezárása.

Bitfield Mouseover: Amennyiben az egeret a regiszter fölé mozgatjuk, megjelenik 
az adott regiszterhez tartozó bitmező.

Find...: Keresés az SFR regiszterek között.

Find Next: Következő keresése.

Go To... Adott címre ugrás az SFR regisztertartományban.

Output To fájl...: Ablakinformáció mentése text fájlba.

Print...: Nyomtatás.

Refresh: Kézi frissítés.

Help: Segítség kérése. Az MPLAB IDE help SFR ablakra vonatkozó 
részét nyitja meg a program.

Properties: A megjelenítés tulajdonságait állíthatjuk be (mutatott oszlopok, 
és színek).

View → Watch: A  menüpont  segítségével  előhívhatjuk  a  Watch (figyelő) 
ablakot  –  melyben  a  processzor  regisztereinek  értékeit 
követhetjük  nyomon  hibakeresés  közben.  Gyakran  csupán 
néhány regiszter értékének változására vagyunk kíváncsiak – 
ebben  az  esetben  zavaró  lehet  a  teljes  regisztertartományt 
(View  →  File  Registers)  vizsgálni.  A  Watch ablakban  csak 
azokat a regisztereket jelenítsük meg, melyek a program(rész) 
szempontjából valós információtartalommal bírnak.
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Add SFR: Speciális funkciójú regiszter hozzáadása a Watch ablakhoz.

Add Symbol: Regiszterek hozzáadása a Watch ablakhoz a regiszter 
szimbolikus jelölése alapján.

Update: A gombra  kattintva  kézi  frissítést  eszközölhetünk  a  Watch 
ablakban.

Address: Regiszter címe (a gombra kattintva cím szerinti egyenes, vagy 
fordított sorrendet kérhetünk a felsorolásban).

Symbol Name: Regiszter  szimbolikus  neve  (a  gombra  kattintva  név  szerinti 
egyenes, vagy fordított sorrendet kérhetünk a felsorolásban).

Value: Regiszter értéke (a gombra kattintva érték szerinti egyenes, 
vagy fordított sorrendet kérhetünk a felsorolásban).
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Az ablakban történő jobb egérgombbal való kattintással további opciókat érünk el:

Close: Watch ablak bezárása.

SFR Bitfield Mouseover: Az SFR regiszterek fölé vitt egérmutató megjeleníti az adott 
regiszterhez tartozó bitmezőt.

Find...: Keresés a Watch ablakban karakterláncra.

Add: Regiszter hozzáadása (a programmemóriában tárolt értékeket 
is hozzá lehet adni a Watch ablakhoz).

Delete: Kijelölt regiszter(ek) törlése az ablakból.

Save Watch Tab...: Watch ablak elmentése (aktuális fül).

Load Watch Tab...: Watch ablak betöltése (új fülként jelenik meg).

Add Watch Tab: Watch ablakhoz egy már elmentett fül hozzáadása.

Rename Watch Tab...: Watch ablak átnevezése (aktuális fül).

Remove Watch Tab: Watch ablak törlése (aktuális fül).

Import Table: Táblázat importálása (*.MCH).

75/102

Figyelő ablak opciói



Programfejlesztés az MPLAB fejlesztőkörnyezetben

Export Table: Táblázat exportálása (*.MCH).

Output To fájl...: Watch  ablak által megjelenített információ  text fájlba történő 
mentése.

Print...: Watch ablak nyomtatása.

Refresh: Watch ablak kézi frissítése.

Help: Az MPLAB IDE help Watch ablakra vonatkozó részét jeleníti 
meg a program.

Properties: Watch ablak tulajdonságainak beállítása.

Symbol: A Watch ablakban megjelenített szimbólum neve.

Size: A szimbólumhoz tartozó adatméret.

Format: A szimbólum megjelenítési formátuma.
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Signed: A szimbólumot előjeles formátumban jelenítjük meg.

Byte Order: Több  bájtos  regiszter  esetén  megadhatjuk  a  megjelenítési 
sorrendet.

Memory: A szimbólum helye (programmemória, vagy adatmemória).

Float Format: Lebegőpontos formátum.

Use COFF Float Type: Alapértelmezett lebegőpontos formátum – további információk 
a Common Object File Format fájlban (*.COFF).

IEEE 754 32-bit: PIC18 mikrovezérlő fordítójához (2.40 verzió vagy későbbi) és 
a HI TECH C-hez rendelt 32 bites formátum.

IEEE Modified 24-bit: HI-TECH C 24 bites formátuma.

Microchip High:Low: PIC 18 mikrovezérlő fordítójának (2.40 verzió előtti).

Microchip Low_High: CCS (C nyelv) fordítójának formátuma.

Default Type Format: Alapértelmezett fixpontos számformátum.

Hex: Hexadecimális (16-os számrendszer).
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Binary: Bináris (2-es számrendszer).

Decimal: Decimális (10-es számrendszer).

Char: Karakter típus (ASCII).

Byte order: Bájt sorrend.

Fonts: Betűkészlet.

Select Font: A Debug ablakokban használt betűkészlet kiválasztása.

Show Fixed Pitch Only: A betűkészletek közül csak az alkalmazhatóak mutatása.

Colors: Színek.

Change Color: A Debug ablakokban használt színek kiválasztása.
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View → Memory Usage Gauge: Megjeleníti a fejlesztett eszköz memória kihasználtságát.

A memóriatérképen láthatjuk a program és az adatmemória kihasználtságát a projektünkben. 
A programmemóriát alapértelmezetten szavakban jelzi az MPLAB (bájt mértékegységre 
válthatunk az ablakban a jobb egérgomb segítségével). A kijelzéshez szükség van egy debug 
fájl generálására (*.cof, vagy *.elf) – melyet a fordítás során a linker állít elő.

View → Simulator Trace: A processzor utasítás-végrehajtásának monitorozása.

View → Simulator Logic Analyzer: Logikai analizátor használata szimulációs környezetben.
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Programletöltés a mikrovezérlőbe

A lefordított kódot valamilyen szoftver- és hardverállomány segítségével le kell töltenünk a 
mikrovezérlőbe – ezt a folyamatot égetésnek nevezzük. A http://plc.mechatronika.hu weboldalon 
megtaláljuk egy párhuzamos porton kommunikáló égető építési és konfigurálási leírását, valamint 
az ICD2 csatlakoztatását az MPLAB-hoz.

ICD2-vel történő programletöltés:

Válasszuk ki programozónak az ICD2 debuggert (Programmer → Select Programmer → MPLAB 
ICD 2)!

Select Programmer: Programozó eszköz kiválasztása.

MPLAB ICD 2 Setup Wizard...: ICD2 beállítása varázsló.

Program: Program letöltése az eszközbe.

Read: Program olvasása az eszközből.

Verify: Ellenőrzés visszaolvasással.

Erase Part: Eszköz memóriájának törlése.

Blank Check: Ellenőrzi, hogy az eszköz üres-e.

Read EEPROM: EEPROM adatmemória beolvasása az eszközből.
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Release from Reset: Reszetfeltétel megszüntetése (L → H).

Hold in Reset: Reszetfeltétel megadása (H → L).

Abort Operation: Bármely programozóművelet megszakítása.

Connect: ICD2 csatlakoztatás.

Download ICD2 Operating System: Az ICD2 operációs rendszerének letöltése.

Settings: Beállítások.

ICD2 inicializálása a varázsló segítségével (Programmer → MPLAB ICD 2 Setup Wizard):

A bejelentkező képernyőn egy üdvözlőüzenettel találkozunk. Az ablakban lévő információ 
szerint  a  varázsló  segít  nekünk  az  MPLAB  ICD2  debugger  beállításában.  Amennyiben 
elolvastuk kattintsunk a Next gombra.
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A következő lépésben beállíthatjuk a  kommunikáció  fajtáját  és  sebességét.  A  Microchip 
ICD2 debuggere  képes  soros  porton,  és  USB-n  is  kommunikálni  a  PC-vel.  A megfelelő 
kommunikációs forma és sebesség kiválasztása után kattintsunk a Next gombra.
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A target áramkör tápfeszültségét biztosíthatjuk az ICD2-ről is (debugolásnál figyelemmel 
kell  lennünk arra,  hogy az  USB porton  csak korlátozott  áramot (max.  500 mA) tudunk 
biztosítani).  A céláramkör  tápfeszültségforrásának  kiválasztása  után  kattintsunk  a  Next 
gombra.

Target has own power supply: A céláramkör saját tápforrással van ellátva.

Power target from the MPLAB ICD 2: A  céláramkör  tápfeszültségét  az  ICD2-ről 
biztosítjuk.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

A következő  ablakban  beállíthatjuk,  hogy az  MPLAB IDE automatikusan  próbálja  meg 
csatlakoztatni  az  ICD2 debuggert  a  projekt  behívásakor.  A  Next gombra  kattintva 
továbbléphetünk.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Amennyiben a felbukkanó ablakban lévő opciót bejelöljük az ICD2 automatikusan letölti az 
operációs rendszerét. Kattintsunk a Next gombra a beállítások befejezéséhez.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Az utolsó ablakban egy összegzést láthatunk a beállításainkról – amennyiben nem vagyunk 
megelégedve a  látott  információkkal,  a  Back gombra  kattintva  módosíthatunk.  A  Finish 
gombra kattintva érvényesíthetjük beállításainkat.
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MPLAB ICD2 manuális beállítása (Programmer → Settings...):

Connect Status: Csatlakozás állapota.

Automatically connect at startup: Programozó  kiválasztásakor  automatikus 
csatlakoztatás.

Automatically download firmware is needed: Szükség  esetén  a  firmware automatikus 
letöltése.

Messages: Üzenetekhez tartozó beállítások.

Output to debug file: Üzenetek mentése a debug fájlba.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Self Test: Önteszt.

Target VDD: Céleszköz tápfeszültsége.

Module VPP: ICD2 programozófeszültség.

MCLR GND: MCLR láb feszültsége a földhöz képest.

MCLR VDD: MCLR láb  feszültsége  a  pozitív  táphoz  képes 
képest.

MCLR VPP: MCLR  láb  feszültsége  a 
programozófeszültséghez képest.
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Com Port: Kommunikációs port (USB; COMX).

Baude Rate: A kommunikáció sebessége.
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Device: Fejlesztett eszköz.

A felbukkanó ablakban megtekinthetjük az adott mikrovezérlőtípushoz tartozó ICD2 
korlátozásokat – amennyiben bővebb információra vagyunk kíváncsiak, kattintsunk a 
Details (részletek) gombra.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Allow ICD 2 to select memories and ranges: Memóriával kapcsolatos beállítások 
engedélyezése az ICD2-nek.

Manually select memories and ranges: Kézi memóriabeállítások.

Memories: Memóriatulajdonságok.

Program: Programmemória írása a céláramkörbe.

Configuration: Konfigurációs bitek írása a céláramkörbe.
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EEPROM: EEPROM adatmemória  írása  a  céláramkörbe 
(amennyiben  nincs  kijelölve,  az  EEPROM-ot 
akkor is törli).

ID: Felhasználói azonosító írása a céláramkörbe.

External: Külső memória írása (használatához 
engedélyeznünk kell a külső memória 
használatát Configure → External Memory).

Program Options: MCLR láb  feszültsége  a  pozitív  táphoz  képes 
képest.

Erase all before Program: Program letöltés  előtt  a  targetáramkör  minden 
memóriájának törlése.

Preserve EEPROM on Program: Kijelölés  esetén  az  EEPROM-ban  csak  azokat 
az  értékeket  írjuk,  melyek  nem  felelnek  meg 
beállításainknak.

Program Memory: Programmemóriával kapcsolatos beállítások.

Start: Programmemória  kezdőcíme  (programozáshoz, 
olvasáshoz, ellenőrzéshez).

End: Programmemória  végcíme  (programozáshoz, 
olvasáshoz, ellenőrzéshez).

Full Range: Az  eszköz  teljes  programmemória 
tartományának megadása.

External Memory: Külső memóriával kapcsolatos beállítások.

Start: Külső  memória  kezdőcíme  (programozáshoz, 
olvasáshoz, ellenőrzéshez).

End: Külső memória  végcíme  (programozáshoz, 
olvasáshoz, ellenőrzéshez).

Full Range: Az eszköz teljes külső memória tartományának 
megadása.

Bootloader: Soros letöltőprogrammal kapcsolatos 
beállítások.

User Memory Routins: Bejelölése  esetén  a  felhasználó  által  definiált 
bootloader fájl használata (ellenkező esetben az 
ICD2 saját bootloaderének használata).
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Automatically: Automatikus beállítások.

Program after successfull build: Sikeres fordítás után automatikus programozás.

Run after successfull program: Sikeres beégetés után automatikus futtatás.

Versions: Verzióinformációk.

MPLAB ICD2 Version: MPLAB ICD 2 verziószáma (dátum).

Firmware: Firmware  (MPLAB ICD 2  operációs  rendszer) 
azonosítója (neve).
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Firmware Type: Firmware típusa.

Firmware Version: Firmware verziószáma (dátum).

Bootloader Version: Letöltőprogram verziószáma (dátum).

Debug Exec Version: A  hibakereső  végrehajtó  moduljának 
verziószáma.

A felkínált listából jelöljük be azokat a veszélyeket, melyekről értesítést szeretnénk kapni az 
ICD2-vel történő programozás, és debugolás során.
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Programfejlesztés az MPLAB fejlesztőkörnyezetben

Projekt és workspace elmentése

A fejlesztés befejezése, vagy szüneteltetése esetén mind a projektet mind a munkaasztalt 
mentsük el. Amennyiben a fejlesztőrendszer következő indításakor is ugyanazzal a munkával 
szeretnénk foglalkozni, mellyel a kilépés előtt, akkor mentsük el az ablakelrendezést is.

Projekt mentése: Project → Save Project
Project → Save Project As...

Munkaasztal mentése: File → Save Workspace
File → Save Workspace As...

Ablakelrendezés mentése: Window → Create Window Set...

A félreértések elkerülése végett itt megadjuk, hogy az egyes objektumok (window; projekt; 
workspace; stb) elmentése milyen beállításokra vonatkozik.

Projekt:

• A fordításhoz szükséges fájlok csoportja.
• Fájl társítások a különböző fordító eszközhöz.
• Fordítási beállítások.

Workspace:

• A fejleszteni kívánt, a hibakeresésre és a programozásra használt eszköz kiválasztása.
• Debug és programozó eszköz beállításai.
• A Configure → Settings... menüpont Program Loading fülének beállításai: 

➢ Memória törlés ideje (fordítás előtt, vagy sikeres fordítás után).
➢ Program memória, konfigurációs bitek, EEPROM adatmemória, felhasználói 

azonosító törlése a program betöltése előtt.
• Konfigurációs bitek beállításai.
• Megnyitott ablakok és azok pozíciója.
• Egyéb rendszerbeállítások.

Registry:

• Fordító eszközök neve és elérési útja.
• A Configure → Settings... menüpont Workspace fülének több beállítása.
• A Configure → Settings... menüpont Project fülének összes beállítása.

➢ A projekt bezárásakor minden megnyitott forrás bezárása.
➢ Fordítás előtt a kimeneti ablak törlése.
➢ Projekt mentése fordítás előtt.
➢ Fájlok mentése projekt fordítás előtt (igen, nem, megerősítés kérése).
➢ Fordítás megállítása az első hibánál.
➢ Egy projekt, egy munkaasztal.
➢ Információ az ablakokban látható/nem látható elemekről (oszlopok; split 

windows (elválasztó sáv az ablakokban), stb.).
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INI Files:

• Egyéni ablakrögzítési információk – docking window: olyan ablakok, melyek a 
munkaterületen csak meghatározott helyen jelenhetnek meg (mplab.ini).

• Szövegszerkesztő beállítások (mpeditor.ini).

Window Sets:

• Az MPLAB felületén lévő összes ablak és eszköztár méretének és pozíciójának 
információtartalma.

HEX Files:

• HEX formátum típusa (INHX32; INHX8S; INHX8M; Suppress).
• Program memória, EEPROM, konfigurációs bitek, felhasználói azonosító.
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Az MPLAB IDE fejlesztőkörnyezetben generált fájlok kiterjesztése, és funkciója:

Kiterjesztés Leírás

a Tárolt könyvtári fájl – MPLAB LIB30

asm Assembly nyelvű forrásfájl – MPASM assembler 

c C forrásfájl – MPLAB C18/C30 

chm Szerkesztett HTML Súgó fájl 

cod Szimbolikus információt tartalmazó fájl és tárgykód – MPASM 
assembler 

cof Szimbolikus információt tartalmazó fájl és tárgykód – MPLINK linker 

elf Szimbolikus információt tartalmazó fájl és tárgykód – MPLAB LINK30 

err Hiba fájl – assembler/compiler

evt Esemény fájl - MPLAB ICE 2000 emulátor

exe Program (végrehajtandó) file 

fsti Egy, vagy több gerjesztési fájlt tartalmazó fájl - MPLAB SIM PIC17 
mikrovezérlő család

gld Szkript fájl - MPLAB LINK30 

h C nyelvű include fájl (header) - MPLAB C18/C30 

hex 

Hexadecimális formátumú gépi kód. 
Megjegyzés: Nem minden hex fájl azonos. Függ attól, hogy hogyan 
generáltuk őket. Hex fájlt generálhatunk forrásból, projektben, illetve 

exportálhatjuk is.

inc Assembly nyelvű include fájl - MPASM assembler/MPLAB ASM30 

lib Könyvtári fájl - MPLIB könyvtárak 

lkr Linker szkript fájl - MPLINK linker 

lst Teljes lista (jegyzék) fájl - assembler/compiler 

map Leképző fájl - linker 

mch Exportált adatfájl 

mcp Projekt információs fájl 

mps Fordítási állapotfájl

mcw Workspace információs fájl

o Tárgyfájl - assembler/compiler
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psti Lábakra adott logikai értéket tartalmazó fájl – szimulátor esetén, PIC17 
mikrovezérlő család

rsti Regiszter kezdőértéket tartalmazó fájl – szimulátor esetén, PIC17 
mikrovezérlő család

ssti Szinkron gerjesztési fájl – MPLAB SIM PIC17 mikrovezérlő család 

s Assembly nyelvű forrásfájl – Microchip 16-bites assembler

sbs Szimulátor vezérlőnyelv fájlja – MPLAB SIM 

scl A Stimulus advanced füléből generált SCL fájl – MPLAB SIM 

stc Lábakra adott gerjesztéseket, és regiszterek alapértékét tartalmazó fájl – 
MPLAB SIM 

trc Nyomkövetés során mentésre került fájl 

trg Indítási fájl – MPLAB ICE 2000 emulátor 

xrf Kereszt-referencia fájl – MPASM assembler 
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Alternatív fejlesztés az MPLAB fejlesztőkörnyezetben

Az MPLAB IDE rendszer lehetővé tesz egy vizuális fejlesztései metódust is – melyet a 
Tools → Visual Initializer menüponttal aktiválhatunk.

A VDI elindítása előtt a munkaasztalunkat be kell állítani (fejlesztendő eszköz, stb.). A VDI 
segítségével egyszerűen be tudjuk állítani a mikrovezérlőnk perifériáit, és a konfigurációs biteket. A 
megfelelő konfigurálás után a program assembly kódot generál számunkra, melyet a hasonló 
vizuális nyelveknél megszokott módon nekünk kell kiegészítenünk a működtető programmal, 
funkciókkal. A képen látható bal oldalsávból húzd és vidd módszerrel tudjuk az integrált áramkörbe 
mozgatni az egyes perifériákat – melyekre kattintva elérhetővé válik a konfigurációs felület.
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Vizuális eszköz inicializáló



Programfejlesztés az MPLAB fejlesztőkörnyezetben

• View  Errata: A  kiválasztott  eszközhöz  tartozó 
hibalapot  tekinthetjük  meg  Acrobat  Reader 
segítségével (//Microchip/Docs/XXX.pdf).

• View Data Sheet: A kiválasztott eszközhöz tartozó 
adatlapot  tekinthetjük  meg  Acrobat  Reader 
segítségével (//Microchip/Docs/XXX.pdf).

• Setup Report: Szöveges ablakban vizsgálhatjuk 
meg a processzor, a konfigurációs bitek és a 
perifériák beállításait.

• Interrupt Usage Report: Megszakítás használatról 
kapunk riportot (cím, név)

• SFR Usage by Address Report: A speciális 
funkciójú regiszterekről is készíthetünk riportot – a 
felsorolás a regiszterek címe alapján történik (cím, 
regiszternév,  reszet hatására az értékük, modulok, 
melyekhez tartoznak).

• SFR Usage by Name Report: A speciális funkciójú 
regiszterekről is készíthetünk riportot – a felsorolás 
a regiszterek neve alapján történik (regiszternév, 
cím, reszet hatására az értékük, modulok, 
melyekhez tartoznak).

• Pin Assignment Report: A mikrovezérlő 
lábkiosztásáról kapunk információt.

• Code Generation Options: Az assembly kód 
létrehozására vonatkozó beállítások.

• Code Generation: Assembly kód generálása a VDI 
jelenlegi beállításaival.

• Quick Start: VDI gyorsindítása. Megvizsgálhatunk 
tutorial fájlt a VDI használatához.
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Generate code only when initialization
values do not match POR states: Csak a kód azon részének generálása, 

melyben lévő beállítások nem egyeznek 
meg a bekapcsolási reszetfeltételkor 
fellépő értékekkel.

Generate code only for features/resources
on processor package: Csak a kód azon részének generálása, 

melyeket az adott eszközzel meg lehet 
valósítani.

Comment on code not generated. Az assembly kódot ne lásd el 
megjegyzésekkel.

Generate Read-Modify-Write instruction
sequence for SFR initialization: Az SFR értékmegadásakor olvas-

módosít-ír típusú utasítások használata.
File Name (fájlnév):

Autto Generate file Name: A VDI automatikusan generálja a 
fájlnevet.

File Name: Az automatikusan generált fájl neve.

101/102

A VDI kódgenerálásának beállítása
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VDI Code: VDI kód generálásának engedélyezése.

Configurable Libary Code: Könyvtári kód generálásának engedélyezése.

A VDI használata lerövidítheti a fejlesztési időt, a generált kódot (angol nyelvű) 
megjegyzésekkel is ellátja. Használata akkor célszerű, ha számunkra ismeretlen perifériát 
szeretnénk használni. A vizuális felületen könnyen el tudjuk végezni az inicializálást, majd a 
generált kódot már tetszésünk szerint tudjuk szépíteni. A VDI hátránya, hogy egyenlőre még nem 
minden mikrovezérlőt és perifériát ismer.
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Kódgenerálás engedélyezése
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